Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
Sporadic Timeouts Downloading Modules From Terraform Module Registry
Incident Report for HashiCorp Services
Resolved
Our CDN provider was unable to discover any clear root cause, but offered some ideas for updates we can make that will allow us to better diagnose issues like this going forward.

The Terraform Module Registry has continued to operate normally, so we are closing out this incident.
Posted Jul 30, 2018 - 23:18 UTC
Monitoring
Between 17:30 and 18:50 UTC today, we observed a period of sporadic timeouts between our content distribution network (CDN) and the application layer of the Terraform Module Registry. Everything on the Terraform Module Registry has been functioning normally since 18:50 UTC.

These timeouts were not reflected in any of our application layer monitoring, leading us to believe that the root cause lies somewhere between the CDN and the application. We are reaching out to our CDN provider to see if they can provide further diagnosis.

This incident exposed that we were missing some alerting on the CDN metrics that showed these timeouts. We will be closing this gap soon so we can catch issues like this more quickly in the future.
Posted Jul 30, 2018 - 20:53 UTC
Investigating
We are currently investigating reports of sporadic timeouts returned from `terraform init` operations as Terraform modules are being downloaded from the Registry. We will follow up with our findings.
Posted Jul 30, 2018 - 20:05 UTC
This incident affected: Terraform Registry.