Degraded Terraform Cloud Runs
Resolved·Degraded performance

The fix has been observed to be successful in improving the performance of Run Tasks.

Tue, Feb 4, 2025, 05:24 PM
(2 months ago)
·
Affected components
HCP Terraform
Updates

Resolved

The fix has been observed to be successful in improving the performance of Run Tasks.

Tue, Feb 4, 2025, 05:24 PM

Monitoring

We have deployed a fix to improve Run Task performance and we are monitoring the system for any further degradation.

Tue, Feb 4, 2025, 04:17 PM(1 hour earlier)

Investigating

Our engineering team is continuing to investigate. At this time, only workspaces using the Run Tasks feature appear to be affected. If you are experiencing slow Terraform runs and are not using Run Tasks, please open a ticket with our support team.

Tue, Feb 4, 2025, 12:03 AM(16 hours earlier)

Investigating

Our engineering team is investigating an issue with HCP Terraform. During this time, users may experience slow Terraform runs. We will share another update as soon as we have more information.

Mon, Feb 3, 2025, 09:52 PM(2 hours earlier)