Scheduled Maintenance | HCP Identity System
Complete·Under maintenance

The scheduled maintenance has been completed.

Mon, Jan 20, 2025, 01:00 PM
(2 months ago)
·
Affected components
HCP Portal
Updates

Complete

The scheduled maintenance has been completed.

Mon, Jan 20, 2025, 01:00 PM

In progress

Scheduled maintenance is still in progress. We're expecting maintenance to conclude at 1pm UTC with minimal end-user impact.

Mon, Jan 20, 2025, 10:19 AM(2 hours earlier)

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Mon, Jan 20, 2025, 09:00 AM(1 hour earlier)

Scheduled

Maintenance will begin as scheduled in 60 minutes.

Mon, Jan 20, 2025, 08:00 AM(59 minutes earlier)

Scheduled

HCP Identity will undergo planned maintenance on Monday, January 20th beginning at 09:00 am UTC. We expect this maintenance to be complete within two hours. Users that sign-in/up during this time frame may have to re-authenticate to access HCP/TFC once maintenance completes. We will post updates as necessary throughout the maintenance period.

Wed, Jan 15, 2025, 05:24 PM(4 days earlier)