HCPT Terraform Agent Errors
Resolved·Degraded performance

The HCP Terraform Agent image 1.20.0 is released and confirmed to address the problems in 1.19.0. Please upgrade your agent to 1.20.0 or later if you are experiencing any issues with 1.19.0.

Thu, Feb 6, 2025, 11:32 PM
(1 month ago)
·
Affected components
HCP Terraform
Updates

Resolved

The HCP Terraform Agent image 1.20.0 is released and confirmed to address the problems in 1.19.0. Please upgrade your agent to 1.20.0 or later if you are experiencing any issues with 1.19.0.

Thu, Feb 6, 2025, 11:32 PM

Monitoring

We have confirmed that errors were triggered by an update to the base operating system image for the HCP Terraform Agent, and we’ve published a new agent image, 1.20.0, which rolls back that update. If you are experiencing trouble with 1.19.0, we recommend updating your tfc-agent image to a later release.

Thu, Feb 6, 2025, 09:45 PM(1 hour earlier)

Monitoring

We have confirmed that a recent release of the HCP Terraform Agent is causing errors for some users. We have rolled back to the previous release for remote Terraform runs and will continue to monitor for further problems. If you are experiencing issues with version 1.19.0 of the agent, we recommend rolling back to 1.18.0 or earlier.

Thu, Feb 6, 2025, 05:52 PM(3 hours earlier)