HCP Terraform Outage
Resolved·Full outage

Our Engineering team has resolved the issue. HCP Terraform should now be operating normally. We ask that customers that noticed issues with Terraform operations since 15:40 UTC retry their workloads at this time. For VCS connected Workspaces/Stacks, please try pushing a no-op commit. If any issues persist, please reach out to our support team.

Fri, Mar 21, 2025, 06:56 PM
(2 weeks ago)
·
Affected components
HCP Terraform
Updates

Resolved

Our Engineering team has resolved the issue. HCP Terraform should now be operating normally. We ask that customers that noticed issues with Terraform operations since 15:40 UTC retry their workloads at this time. For VCS connected Workspaces/Stacks, please try pushing a no-op commit. If any issues persist, please reach out to our support team.

Fri, Mar 21, 2025, 06:56 PM

Resolved

Our Engineering team has resolved the issue. HCP Terraform should now be operating normally. We ask that customers that noticed issues with Terraform operations since 15:40 UTC retry their workloads at this time. If any issues persist, please reach out to our support team.

Fri, Mar 21, 2025, 05:10 PM(1 hour earlier)

Monitoring

Our Engineering team has identified a routine infrastructure change that rendered storage services unavailable, a fix has been implemented to resolve the issue. We are monitoring the situation closely and will post an update as soon as the issue is fully resolved. At this time we recommend customers hold off on retrying their workloads. The next status update will be provided before 17:50 UTC.

Fri, Mar 21, 2025, 04:48 PM(22 minutes earlier)

Investigating

We are aware of and investigating an outage affecting HCP Terraform. Our team is working to identify and resolve the issue. We will post updates with more information as it becomes available, the next update can be expected in roughly an hour at 16:50 UTC.

Fri, Mar 21, 2025, 03:51 PM(56 minutes earlier)