SSO logins are stuck for HCP Terraform users
Resolved·Partial outage

We’ve resolved the issue affecting SSO logins for HCP Terraform users who were HCP Account-linked but originally started with an HCP Terraform account. The root cause was identified and addressed, and SSO functionality has been restored. All impacted users should now be able to sign in normally. No further action is required, but users who previously followed the workaround may continue using their Terraform credentials or relink their HCP account if preferred.

Thu, Apr 3, 2025, 04:20 PM
(1 day ago)
·
Affected components
HCP Terraform
Updates

Resolved

We’ve resolved the issue affecting SSO logins for HCP Terraform users who were HCP Account-linked but originally started with an HCP Terraform account. The root cause was identified and addressed, and SSO functionality has been restored. All impacted users should now be able to sign in normally. No further action is required, but users who previously followed the workaround may continue using their Terraform credentials or relink their HCP account if preferred.

Thu, Apr 3, 2025, 04:20 PM

Investigating

The investigation is actively ongoing, and while we are working on a fix, customers who are HCP Account-linked but started with an HCP Terraform account can follow the provided workaround. Impact HCP Terraform users with SSO identities who are linked to an HCP account Workaround for customers who are linked but started with an HCP Terraform account originally 1. Sign into HCP Terraform using your HCP username/password account 2. Go to user dropdown > account settings > HCP Account Linking 3. Select "unlink account" 1. This should log you out and unlink your account 4. Log in using your HCP Terraform credentials, not using the "continue with HCP" button 1. If you don't remember your Terraform password, you can use the forgot password flow to retrieve it 2. You can also at this point use the Sign in with Terraform SSO

Thu, Apr 3, 2025, 03:10 PM(1 hour earlier)

Investigating

Our Engineering team has identified the cause and we are actively working on a fix. Once we have additional information, we will share another update. Impact HCP Terraform users with SSO identities who are linked to an HCP account Workaround for customers who are linked but started with an HCP Terraform account originally

  • Sign into HCP Terraform using your HCP username/password account

  • Go to user dropdown > account settings > HCP Account Linking

  • Select "unlink account"

    • This should log you out and unlink your account

  • Log in using your HCP Terraform credentials, not using the "continue with HCP" button

    • If you don't remember your Terraform password, you can use the forgot password flow to retrieve it

    • You can also at this point use the Sign in with Terraform SSO

Thu, Apr 3, 2025, 06:46 AM(8 hours earlier)

Identified

Our Engineering team has identified the cause and we are actively working on a fix. Once we have additional information, we will share another update.

Thu, Apr 3, 2025, 05:58 AM(48 minutes earlier)

Investigating

SSO logins are stuck for HCP Terraform users. This issue is impacting HCP Terraform users with SSO identities who have also linked their accounts to an HCP account. Impact to non-linked accounts is not reported.

Thu, Apr 3, 2025, 05:54 AM