Issue with inviting new users
Resolved·Partial outage

Our Engineering team has resolved the issue. These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.

Wed, Aug 27, 2025, 08:42 PM
(2 days ago)
·
Affected components
HCP Portal
Updates

Resolved

Our Engineering team has resolved the issue. These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.

Wed, Aug 27, 2025, 08:42 PM

Monitoring

Our Engineering team is monitoring the situation closely and will post an update as soon as the issue is fully resolved.

New invites should work as expected. If an existing invite is not working, use the "Resend invite" option on the Pending invites page.

Wed, Aug 27, 2025, 06:31 PM(2 hours earlier)

Identified

Our Engineering team has identified the cause and we have implemented a fix.

New invites should work as expected. If an existing invite is not working, use the "Resend invite" option on the Pending invites page.

Wed, Aug 27, 2025, 06:18 PM(12 minutes earlier)

Investigating

We are aware of and investigating an issue that is impacting the ability to invite new users to organizations. Our team is working to identify and resolve the issue. We will post updates with more information as it becomes available.

Wed, Aug 27, 2025, 05:51 PM(27 minutes earlier)