GitHub has completed remediation of the SSH deploy key incident. Terraform runs using GitHub-hosted modules/sources over SSH have recovered, clone operations are functioning normally, and no further authentication failures are being observed.
Resolved
GitHub has completed remediation of the SSH deploy key incident. Terraform runs using GitHub-hosted modules/sources over SSH have recovered, clone operations are functioning normally, and no further authentication failures are being observed.
Monitoring
GitHub has completed remediation of the incident affecting SSH deploy keys. Terraform runs using GitHub-hosted modules and sources over SSH have recovered, and clone operations are functioning normally. We are no longer observing related authentication failures and will continue monitoring.
Monitoring
GitHub has completed remediation of the incident affecting SSH deploy keys. Terraform runs using GitHub-hosted modules and sources over SSH have recovered, and clone operations are functioning normally. We are no longer observing related authentication failures and will continue monitoring.
Investigating
We are investigating failures cloning GitHub-hosted Terraform modules and sources over SSH, caused by an ongoing upstream GitHub incident affecting SSH deploy keys. Runs using git::ssh:// or git@github.com: sources may fail with Permission denied (publickey); HTTPS and registry-based sources are unaffected. We're tracking GitHub's remediation and will update as we learn more.