Our Engineering team has resolved the issue. We released the Terraform AWS Provider v6.60.0 with a fix. Affected systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Resolved
Our Engineering team has resolved the issue. We released the Terraform AWS Provider v6.60.0 with a fix. Affected systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Identified
Our engineering team has identified the cause of the "Missing Resource Identity After Read" errors and has completed a fix. We are preparing version 6.60.0 of the Terraform AWS Provider, which includes this fix. v6.60.0 is not yet available in the registry.
This affects aws_network_acl_rule resources that were created with provider versions earlier than 6.39.0. Terraform runs that do not manage aws_network_acl_rule resources are unaffected.
Users encountering errors can continue running Terraform by pinning the provider to version 6.58.0:
terraform {
required_providers {
aws = {
source = "hashicorp/aws"
version = "6.58.0"
}
}
}