No components marked as affected
Resolved
This incident has been resolved.
Investigating
Experiencing degraded performance on Policy Check runs where the check is queued for a longer than normal time. The current workaround would be to cancel the run and re-queue it.