Investigating Issues with HCP Portal
Resolved
Degraded performance

Our Engineering team has resolved the issues with HCP Portal. These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.

Mon, Feb 24, 2025, 08:00 PM
2 weeks ago
Affected components
HCP Portal
Updates

Resolved

Our Engineering team has resolved the issues with HCP Portal. These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.

Mon, Feb 24, 2025, 08:00 PM
2h earlier...

Monitoring

Our Engineering team has implemented a fix to resolve the issue with HCP Portal. We are monitoring the situation closely and will post an update as soon as the issue is fully resolved.

Mon, Feb 24, 2025, 05:30 PM
35m earlier...

Investigating

Our engineering team is investigating issues with HCP Portal. We will share another update as soon as we have more information.

Mon, Feb 24, 2025, 04:54 PM