HCP Login issues
Resolved·Partial outage

Our Engineering team has resolved the issue. Login should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.

Tue, Apr 29, 2025, 05:55 PM
(2 weeks ago)
·
Affected components
HCP Portal
Updates

Resolved

Our Engineering team has resolved the issue. Login should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.

Tue, Apr 29, 2025, 05:55 PM

Monitoring

Our Engineering team has implemented a fix to resolve the issue. If you are still experiencing issues logging in, please contact our support team.

Tue, Apr 29, 2025, 04:39 PM(1 hour earlier)

Investigating

We are aware of and investigating reports of difficulty logging in to HCP. Our team is working to identify and resolve the issue. We will post updates with more information as it becomes available.

Tue, Apr 29, 2025, 04:01 PM(37 minutes earlier)