HCP Terraform "Apply" Button
Resolved

Our Engineering team has resolved the issue. These systems should now be operating normally. Some customers may need to perform a hard refresh on the page. If you continue to experience issues, please reach out to support.

Thu, Jul 31, 2025, 11:06 PM
(2 weeks ago)
·
Affected components

No components marked as affected

Updates

Resolved

Our Engineering team has resolved the issue. These systems should now be operating normally. Some customers may need to perform a hard refresh on the page. If you continue to experience issues, please reach out to support.

Thu, Jul 31, 2025, 11:06 PM

Monitoring

Our Engineering team has implemented a fix to resolve the issue. We are monitoring the situation closely and will post an update as soon as the issue is fully resolved.

Thu, Jul 31, 2025, 09:14 PM(1 hour earlier)

Investigating

We are aware of and investigating reports of issues with the "Apply" button in the HCP Terraform UI. Our team is working to identify and resolve the issue. We will post updates with more information as it becomes available.

Thu, Jul 31, 2025, 09:04 PM