Azure DevOps VCS Connections in HCP Terraform
Resolved·Degraded performance

Microsoft has applied a fix for this issue. ADO related services are functioning normally now for Australia region

Wed, Aug 13, 2025, 12:29 PM
(5 days ago)
·
Affected components
HCP Terraform
Updates

Resolved

Microsoft has applied a fix for this issue. ADO related services are functioning normally now for Australia region

Wed, Aug 13, 2025, 12:29 PM

Investigating

We are currently investigating an issue with degraded performance affecting workspaces connected via Azure DevOps VCS, specifically in the Australia region.
Please note that HCP Terraform is fully operational and not experiencing a platform-wide outage.
Initial indications suggest the issue may be related to Microsoft's services. Our engineering team is actively working to verify this and continues to monitor and investigate the situation closely.
We will provide updates as more information becomes available. Thank you for your patience.

Wed, Aug 13, 2025, 06:12 AM(6 hours earlier)

Monitoring

After conducting a comprehensive investigation, our engineering team has verified that every VCS connection is operational and functioning as it should. We are monitoring the situation closely and will post an update as soon as we receive confirmation from affected Customers

Wed, Aug 13, 2025, 05:58 AM(14 minutes earlier)

Investigating

We are aware of and investigating reports of degraded performance related to workspaces backed by Azure DevOps VCS connections. Our team is working to identify and resolve the issue. We will post updates with more information as it becomes available.

Wed, Aug 13, 2025, 05:39 AM(18 minutes earlier)

Monitoring


After conducting a comprehensive investigation, our engineering team has verified that Azure DevOps VCS connections are operational and functioning as expected. We are monitoring the situation closely and will post an update as soon as we receive confirmation from affected Customers

Tue, Aug 12, 2025, 01:49 PM(15 hours earlier)

Monitoring

After conducting a comprehensive investigation, our engineering team has verified that every VCS connection is operational and functioning as it should. We are monitoring the situation closely and will post an update as soon as we receive confirmation from affected Customers

Tue, Aug 12, 2025, 01:45 PM

Investigating

We are aware of and investigating reports of degraded performance related to workspaces backed by Azure DevOps VCS connections. Our team is working to identify and resolve the issue. We will post updates with more information as it becomes available.

Tue, Aug 12, 2025, 12:21 PM(1 hour earlier)