Terraform Public Registry is currently experiencing degraded performance
Resolved·Degraded performance

These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.

Thu, Dec 11, 2025, 06:42 PM
(2 days ago)
·
Affected components
Terraform Registry
Updates

Resolved

These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.

Thu, Dec 11, 2025, 06:42 PM

Monitoring

Our Engineering team believes the issue is resolved and is monitoring the situation closely. We will post an update as soon as the issue is fully resolved.

Thu, Dec 11, 2025, 06:08 PM(33 minutes earlier)

Investigating

We are continuing to see degraded performance with Terraform Public Registry. We will post updates with more information as it becomes available.

Thu, Dec 11, 2025, 05:19 PM(48 minutes earlier)

Investigating

We are aware of and investigating reports of degraded performance with Terraform Public Registry. We will post updates with more information as it becomes available.

Thu, Dec 11, 2025, 04:30 PM(49 minutes earlier)