Resolved
Our Engineering team has resolved the issue. These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Monitoring
Our Engineering team has released a fix for the Stacks validation errors, and backported it to Terraform 1.14.
The fix will make it’s way into the 1.15 pre-release through the normal pre-release process.
Identified
Our Engineering team is currently working on releasing a fix for the Stacks validation errors, and backporting it to Terraform 1.14. The release is expected to be available before 22:00 UTC.
The fix will make it’s way into the 1.15 pre-release through the normal pre-release process.
The next update can be expected around 20:00 UTC.
Identified
Our Engineering team has identified the cause of GPG validation errors with Terraform: only new installations that need to install the Stacks Plugin are affected.
Our Engineering team is actively working on a fix, and backports for the fix to Terraform 1.14, 1.13, and 1.15 (currently pre-release).
We do not have an ETA for the completion of this work at this time.
The next update can be expected around 18:00 UTC.
Identified
Our engineering team has identified the cause of GPG validation errors with Terraform.
For Terraform:
Only consumers of Stacks are affected.
Engineers are actively working on a fix.
The next update can be expected around 16:00 UTC.
Identified
Our engineering team has identified the cause of GPG validation errors with Terraform and hc-install.
For hc-install:
A new release has been cut (v0.9.4) which should address key rotation errors.
Affected workflows should update their hc-install version and retry.
For Terraform:
Only consumers of Stacks are affected.
Engineers are actively working on a fix.
The next update can be expected around 15:00 UTC.
Investigating
We are aware of and investigating errors that started occurring over the weekend as a result of the rotation of our GPG key for security@hashicorp.com (C874011F0AB405110D02105534365D9472D7468F).
The errors currently affect the use of Terraform, and hc-install.