Resolved
Our Engineering team has resolved the issue. These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Monitoring
Starting at 12:18 EDT, for approximately 45 minutes, organization creation on the HCP Portal was unable to complete due to a validation bug. Engineers rolled back the change and there should be no further complications creating HCP organizations. If you are experiencing further difficulties please contact support.