HCP Terraform Latency Degredation
Resolved·Degraded performance

The applied mitigations have successfully resolved the issue.

During the incident customers may have noticed Terraform Runs failing due to the increased latency: those can now be retried.

Wed, Jul 17, 2024, 04:22 PM
(9 months ago)
·
Affected components
HCP Terraform
Updates

Resolved

The applied mitigations have successfully resolved the issue.

During the incident customers may have noticed Terraform Runs failing due to the increased latency: those can now be retried.

Wed, Jul 17, 2024, 04:22 PM

Monitoring

Engineers have rolled back the problematic change, and have observed signs of recovery. We are currently monitoring the application to ensure a return to normal operation.

Wed, Jul 17, 2024, 03:38 PM(44 minutes earlier)

Identified

Our Engineering team has identified and is currently attempting to mitigate a change that has increased latency on HCP Terraform. Customers are likely experiencing large increases in latency across Workspace and Run api endpoints.

Wed, Jul 17, 2024, 02:55 PM(43 minutes earlier)