Consul Managed App deployment is failing with 'unauthorized' error
Incident Report for HashiCorp Services
Resolved
Microsoft have reported that a fix has been applied.
We have been monitoring our workflows and we see that the issue has been resolved.

If you see further issues please contact HashiCorp Support.

We apologize for this disruption in service and appreciate your patience.

Hashicorp Cloud Team
Posted Nov 10, 2020 - 11:04 UTC
Identified
Microsoft have reported back to us that there is an issue at their end that is causing this problem. They are investigating and will report back to us when they have a fix.
Posted Nov 10, 2020 - 08:09 UTC
Investigating
We are investigating an issue where Consul Azure Managed App deployments are failing. This appears to be affecting all creation requests, which are failing with an error message of "The resource provider 'public' received a non-success response 'Unauthorized'".

We have escalated this to the Azure Managed App Support team, who are working with us to identify the cause.
Posted Nov 10, 2020 - 07:13 UTC
This incident affected: HashiCorp Consul Service (HCS) on Azure (Creation via Azure Marketplace).