Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
Administrative tasks against Vault and Consul clusters are degraded
Incident Report for HashiCorp Services
Resolved
Our Engineering team has resolve the issues causing degraded administrative actions against HCP Consul and HCP Vault clusters.

All operations are healthy.

These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Posted Feb 23, 2024 - 01:27 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 22, 2024 - 23:21 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue of degraded administrative tasks against HCP Vault and HCP Consul clusters.

We are beginning to see recovery and are monitoring the situation closely and will post an update as soon as the issue is fully resolved.
Posted Feb 22, 2024 - 23:13 UTC
Identified
Our Engineering team has identified the cause for the following incident:

Administrative tasks against Vault and Consul clusters are degraded (cluster creation, deletion, generation of admin tokens, snapshot operations, etc).

Existing Vault and Consul clusters will continue to operate without issue.

We are actively working on a fix. Once we have additional information, we will share another update.
Posted Feb 22, 2024 - 22:20 UTC
Investigating
Our engineering team is investigating an issue with the following:

HCP Vault cluster creation and admin token generation is degraded.

During this time, users may experience the following:

Failure to create new HCP Vault clusters
Failure to generate admin tokens

We will share another update as soon as we have more information.
Posted Feb 22, 2024 - 21:45 UTC
This incident affected: HCP Vault Dedicated (AWS-ap-northeast-1, AWS-ap-southeast-1, AWS-ap-southeast-2, AWS-ca-central-1, AWS-eu-central-1, AWS-eu-west-1, AWS-eu-west-2, AWS-us-east-1, AWS-us-east-2, AWS-us-west-2, Azure-Australia Southeast, Azure-Canada Central, Azure-Central US, Azure-East US, Azure-East US 2, Azure-France Central, Azure-Japan East, Azure-North Europe, Azure-Southeast Asia, Azure-UK South, Azure-West Europe, Azure-West US 2) and HCP Consul Dedicated (AWS-ap-northeast-1, AWS-ap-southeast-1, AWS-ap-southeast-2, AWS-ca-central-1, AWS-eu-central-1, AWS-eu-west-1, AWS-eu-west-2, AWS-us-east-1, AWS-us-east-2, AWS-us-west-2, Azure-Australia Southeast, Azure-Canada Central, Azure-Central US, Azure-East US, Azure-East US 2, Azure-France Central, Azure-Japan East, Azure-North Europe, Azure-Southeast Asia, Azure-UK South, Azure-West Europe, Azure-West US 2).