Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
RPM Repo GPG Key Failure
Incident Report for HashiCorp Services
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 05:40 UTC
Update
The signing issue impacting RPM signing keys has been resolved. We expect EL7 use cases to require the practitioner to run "yum --enablerepo=hashicorp clean metadata", and EL8+ and Fedora to not require any repairs by practitioners.
Posted Jan 24, 2023 - 05:23 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 24, 2023 - 01:04 UTC
Identified
The issue has been identified that affects Linux el7 families which includes AmazonLinux{2, latest} and RHEL/CentOS7. A fix is being implemented.
Posted Jan 23, 2023 - 22:28 UTC
Investigating
There are reports of GPG key failures showing failures when pulling RPM packages due to the key rotation maintenance earlier today for repository configuration set up prior to maintenance with the old key. New installations are not affected when following the steps outlined in https://www.hashicorp.com/official-packaging-guide.
Posted Jan 23, 2023 - 21:17 UTC
This incident affected: Releases (RPM Repository).