Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
HCP Vault Create/Update/Delete Failures
Incident Report for HashiCorp Services
Resolved
Our Engineering team has resolved the issue with create, update, and deletion operations in the portal for HCP Consul, HCP Packer, HCP Vault, and HCP Boundary. These services should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Posted Feb 02, 2023 - 21:41 UTC
Update
We are currently monitoring create, update and deletion operations in the portal for HCP Consul, HCP Packer, HCP Vault and HCP Boundary, which had an outage for the past hour. We will share another update as soon as we have more information.
Posted Feb 02, 2023 - 20:36 UTC
Update
We are continuing to monitor the situation and will post another update within 24 hours. Self-managed clusters that have been linked to HCP Consul remain invisible on the HCP UI. Some information shown in HCP Consul overview, services and cluster details page may not be visible as well. Clusters on HCP Vault can show warnings about expiring licenses. These can be ignored until further notice.
Posted Feb 01, 2023 - 15:40 UTC
Update
We are continuing to monitor the situation and will post another update within 24 hours.

Self-managed clusters that have been linked to HCP Consul remain invisible on the HCP UI. Some information shown in HCP Consul overview, services and cluster details page may not be visible as well.

Clusters on HCP Vault can show warnings about expiring licenses. These can be ignored until further notice.
Posted Jan 31, 2023 - 22:20 UTC
Update
The Boundary, Consul and Vault services on the HashiCorp Cloud Platform are operational. Customers should no longer experience latency.

Self-managed clusters that have been linked to HCP Consul will not be visible on the HCP UI. Some information shown in HCP Consul overview, services and cluster details page may not be visible as well.

Clusters on HCP Vault can show warnings about expiring licenses. These can be ignored until further notice.
Posted Jan 31, 2023 - 14:06 UTC
Update
The Boundary, Consul and Vault services on the HashiCorp Cloud Platform are operational. Customers should no longer experience latency.

Self-managed clusters that have been linked to HCP Consul will not be visible on the HCP UI. Some information shown in HCP Consul overview, services and cluster details page may not be visible as well.

Self-managed Vault clusters can show warnings about expiring licenses. These can be ignored until further notice.
Posted Jan 31, 2023 - 13:45 UTC
Monitoring
We are seeing successful create/update/delete actions for the platform. Services have recovered, customers should no longer experience latency. We will monitor the situation.

Self-managed clusters that have been linked to HCP Consul will not be visible on the HCP UI. Some information shown in HCP Consul Overview, services and cluster details page may not be visible as well.
Posted Jan 31, 2023 - 01:28 UTC
Update
Customer side services have recovered, with moderately higher latencies still being present. HCP engineers are monitoring system health, as well as determining and remediating root cause.

Self-managed clusters that have been linked to HCP Consul will not be visible on the HCP UI. Some information shown in HCP Consul Overview, services and cluster details page may not be visible as well.

The update cadence will be lengthened, and notifications will be sent when further discoveries or improvements are made.
Posted Jan 30, 2023 - 23:55 UTC
Update
Customer side services have recovered, with moderately higher latencies still being present. HCP engineers are monitoring system health, as well as determining and remediating root cause.

Self-managed clusters that have been linked to HCP Consul will not be visible on the HCP UI. Some information shown in HCP Consul Overview, services and cluster details page may not be visible as well.

The update cadence will be lengthened, and notifications will be sent when further discoveries or improvements are made.
Posted Jan 30, 2023 - 22:24 UTC
Update
Customer side services have recovered, with moderately higher latencies still being present. HCP engineers are monitoring system health, as well as determining and remediating root cause.
The update cadence will be lengthened, and notifications will be sent when further discoveries or improvements are made.
Posted Jan 30, 2023 - 21:07 UTC
Update
We have validated that create/update/delete actions are succeeding, and customer side services have recovered. Moderately higher latencies may still be present. HCP engineers are monitoring system health, as well as determining and remediating root cause.
Posted Jan 30, 2023 - 18:43 UTC
Update
We have validated that create/update/delete actions for the platform are succeeding consistently. High latencies are still present in these calls. HCP engineers will continue to monitor the health of the platform.
Posted Jan 30, 2023 - 17:34 UTC
Update
We have validated that create/update/delete actions for the platform are succeeding consistently. High latencies are still present in these calls. HCP engineers will continue to monitor the health of the platform.
Posted Jan 30, 2023 - 17:31 UTC
Identified
We are seeing successful create/update/delete actions for the platform. High latencies are still present in these calls. HCP engineers will continue to monitor the health of the platform.
Posted Jan 30, 2023 - 17:06 UTC
Update
We are seeing successful create/update/delete actions for the platform. High latencies are still present in these calls. HCP engineers will continue to monitor the health of the platform.
Posted Jan 30, 2023 - 17:03 UTC
Update
We are continuing to investigate issues with create, update and deletion operations in the portal for HCP Consul, HCP Vault and HCP Boundary. We will share another update as soon as we have more information.
Posted Jan 30, 2023 - 16:10 UTC
Investigating
We are aware of high latency and failures for create/update/delete operations on the portal. HCP engineers are currently investigating and will provides updates.
Posted Jan 30, 2023 - 11:59 UTC
This incident affected: HCP Portal, HCP Boundary, HCP Consul, HCP Packer, and HCP Vault.