Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
HCP Vault Secrets unable to create new secrets
Incident Report for HashiCorp Services
Resolved
Our Engineering team has fully resolved the issue causing errors for secret writes and increased latency for secret reads in HCP Vault Secrets. The issue was related to the AWS CloudWatch log service degradation which has been resolved as well.

HCP Vault Secrets should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Posted Jul 31, 2024 - 19:12 UTC
Monitoring
This issue is caused by the ongoing AWS incident, which is leading to degradation of CloudWatch log service.

We have successfully deployed a fix to address this issue. As a result, the errors related to creating new secrets as well as the latency issues have both been resolved.
Posted Jul 31, 2024 - 01:37 UTC
Identified
HCP Vault Secrets is failing to write secrets, reading secrets is experiencing higher than usual latency. The issue has been identified and engineers are working to solve the problem.
Posted Jul 30, 2024 - 23:16 UTC
This incident affected: HCP Vault Secrets.