Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
Identified an incident with IAM Group Management
Incident Report for HashiCorp Services
Resolved
Our Engineering team has resolved the following issue:

IAM Group Management Broken

You can now manage groups and group membership. Groups can also once again be added and removed from Projects.

These systems should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Posted May 06, 2024 - 22:01 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with:

Removal of members from an IAM Group.

We are monitoring the situation closely and will post an update as soon as the issue is fully resolved.
Posted May 06, 2024 - 20:47 UTC
Identified
Our Engineering team has identified the cause for the following incident:

IAM Group members cannot be removed from an IAM Group.

We are actively working on a fix. Once we have additional information, we will share another update.
Posted May 06, 2024 - 19:44 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with:

Management of IAM Groups

We are monitoring the situation closely and will post an update as soon as the issue is fully resolved.
Posted May 06, 2024 - 18:35 UTC
Identified
Our Engineering team has identified the cause for the following incident:

A feature flag conflict is preventing some users from editing IAM Groups or changing project assignments of IAM Groups.

We are actively working on a fix. Once we have additional information, we will share another update.
Posted May 06, 2024 - 17:19 UTC
Investigating
Our engineering team is investigating an issue with the following:

HCP Portal IAM Group Editing

During this time, users may experience the following:

Some users may be experiencing problems editing IAM Groups or changing project assignments of IAM Groups.

We will share another update as soon as we have more information.
Posted May 06, 2024 - 17:03 UTC
This incident affected: HCP Portal.