Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
All Systems Operational
HCP Portal Operational
HCP API Operational
HCP Boundary Operational
HCP Consul Operational
AWS-ap-northeast-1 Operational
AWS-ap-southeast-1 Operational
AWS-ap-southeast-2 Operational
AWS-ca-central-1 Operational
AWS-eu-central-1 Operational
AWS-eu-west-1 Operational
AWS-eu-west-2 Operational
AWS-us-east-1 Operational
AWS-us-east-2 Operational
AWS-us-west-2 Operational
Azure-Australia Southeast Operational
Azure-Canada Central Operational
Azure-Central US Operational
Azure-East US Operational
Azure-East US 2 Operational
Azure-France Central Operational
Azure-Japan East Operational
Azure-North Europe Operational
Azure-Southeast Asia Operational
Azure-UK South Operational
Azure-West Europe Operational
Azure-West US 2 Operational
HCP Packer Operational
HCP Vault Operational
AWS-ap-northeast-1 Operational
AWS-ap-southeast-1 Operational
AWS-ap-southeast-2 Operational
AWS-ca-central-1 Operational
AWS-eu-central-1 Operational
AWS-eu-west-1 Operational
AWS-eu-west-2 Operational
AWS-us-east-1 Operational
AWS-us-east-2 Operational
AWS-us-west-2 Operational
Azure-Australia Southeast Operational
Azure-Canada Central Operational
Azure-Central US Operational
Azure-East US Operational
Azure-East US 2 Operational
Azure-France Central Operational
Azure-Japan East Operational
Azure-North Europe Operational
Azure-Southeast Asia Operational
Azure-UK South Operational
Azure-West Europe Operational
Azure-West US 2 Operational
HCP Vault Secrets Operational
HCP Vault Radar Operational
HCP Waypoint Operational
Terraform Cloud Operational
Terraform Registry Operational
Vagrant Cloud Operational
Waypoint URL Service Operational
Releases Operational
APT Repository Operational
Helm Chart Repository Operational
RPM Repository Operational
Releases Site Operational
Private Container Registry Operational
Linux Package Archive Site Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
Terraform Cloud and Terraform Public Registry will undergo scheduled maintenance on Sunday, April 21st beginning at 17:00 UTC. We expect this maintenance to complete within 4 hours.

During this time, these services will be unavailable until the maintenance completes. We'll post updates as necessary throughout the maintenance period.

Posted on Mar 16, 2024 - 23:29 UTC
HCP Boundary Scheduled Maintenance Apr 27, 2024 16:00-17:00 UTC
HCP Boundary will undergo planned maintenance on Saturday, April 27th, beginning at 16:00 UTC. We expect this maintenance to be completed within one hour. During this time, HCP boundary sessions may disconnect unexpectedly. We will post updates as necessary throughout the maintenance period.
Posted on Apr 16, 2024 - 22:01 UTC
Past Incidents
Apr 20, 2024

No incidents reported today.

Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024
Resolved - The issue has been resolved. Customers with a GitHub App who may have been impacted can retry now that the incident has passed by pushing a new commit.
Apr 11, 15:07 UTC
Monitoring - Fix is deployed and we are currently monitoring.
Apr 11, 14:54 UTC
Identified - GitHub App webhooks are not currently being processed. We have identified a fix and are in the process of remediating.
Apr 11, 14:34 UTC
Apr 10, 2024

No incidents reported.

Apr 9, 2024

No incidents reported.

Apr 8, 2024

No incidents reported.

Apr 7, 2024
Completed - The scheduled maintenance has been completed.
Apr 7, 20:00 UTC
Update - Scheduled maintenance is still in progress. We will provide updates as necessary.
Apr 7, 19:12 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 7, 18:00 UTC
Scheduled - Terraform Cloud will undergo emergency maintenance on 7th April 2024 beginning at 18:00 UTC. We expect this maintenance to be complete within two hours. During this time, Terraform Cloud will be unavailable. We will post updates as necessary throughout the maintenance period.
Apr 2, 20:40 UTC
Apr 6, 2024

No incidents reported.