Terraform Runs Marked as Needs Confirmation
Incident Report for HashiCorp Services
Resolved
We have confirmed that the fix deployed resolves the issue.
Posted 11 days ago. Sep 12, 2018 - 01:00 UTC
Monitoring
We have deployed a fix for the issue and will continue to monitor it.
Posted 11 days ago. Sep 12, 2018 - 00:03 UTC
Update
We have now resolved the issue with runs marked as "Planned" locking the workspace in which they are running. The user interface is still incorrectly marking some runs as "Needs Confirmation", and we are continuing to work on a fix for that issue.
Posted 11 days ago. Sep 11, 2018 - 23:33 UTC
Update
We have identified the commit causing plans with no changes to be marked as “Needs Confirmation” in the UI. Additionally, runs marked as “Planned” may lock the workspace in which they’re running. If the workspace is locked, it is safe to unlock the workspace via the workspace settings page and proceed with any queued or pending plans.
Posted 11 days ago. Sep 11, 2018 - 22:16 UTC
Identified
We have identified the commit causing plans with no changes to be marked as “Needs Confirmation” in the UI. Additionally, runs marked as “Planned” may lock the workspace in which they’re running. If the workspace is locked, it is safe to unlock the workspace and proceed with any queued or pending plans.
Posted 11 days ago. Sep 11, 2018 - 21:58 UTC
Investigating
The user interface is incorrectly marking some runs as "Needs Confirmation". We are investigating.
Posted 11 days ago. Sep 11, 2018 - 21:42 UTC
This incident affected: Terraform Runs.