Terraform Run Slowness and Errors
Incident Report for HashiCorp Services
Resolved
The upstream provider has resolved this issue.
Posted 28 days ago. Jul 18, 2018 - 02:27 UTC
Update
Services are not currently affected but risk continues to be higher than normal. We continue to monitor run times and await final resolution from the provider.
Posted 28 days ago. Jul 18, 2018 - 00:16 UTC
Update
Services are not currently affected but risk continues to be higher than normal. We continue to monitor run times and await final resolution from the provider.
Posted 28 days ago. Jul 17, 2018 - 21:37 UTC
Update
Update: The upstream network issues have stopped causing Terraform slowness and errors; however, we continue to monitor performance and are keeping the status listed as "Degraded Performance" until the upstream provider declares the issue resolved.
Posted 28 days ago. Jul 17, 2018 - 19:29 UTC
Monitoring
At 17:19 UTC today, Terraform plan and apply runs began experiencing above normal run times and failure rates. These problems are being caused by an upstream provider networking issue.

We are monitoring the situation for further updates and evaluating remediation steps.
Posted 28 days ago. Jul 17, 2018 - 18:25 UTC
This incident affected: Terraform Runs.