Workspaces Unavailable
Incident Report for HashiCorp Services
Postmortem

On September 8, 2018 at 12:01am UTC (5:01 PM PDT), Terraform Enterprise incurred 41 minutes of severely degraded service after an intermediate SSL certificate had expired. The certificate expiration prevented the system from retrieving customer data or performing any Terraform plans or applies.

We replaced the certificate, allowing the system to resume normal operation. This certificate was missed in our rollout of a standard auto-renewal certificate process used for all other aspects of the system. We will correct this oversight and perform an audit to identify any other static certificates that have not been converted to auto-renew. Additionally, we are improving our expiration alerts for all certificates to provide early warning for any future expiration issues.

Posted 11 days ago. Sep 11, 2018 - 18:42 UTC

Resolved
This incident has been resolved.
Posted 14 days ago. Sep 08, 2018 - 03:34 UTC
Update
The issue has been fully resolved and all systems are normal.
Posted 15 days ago. Sep 08, 2018 - 01:15 UTC
Monitoring
System should operational now, though we are continuing to monitor and recover the system.
Posted 15 days ago. Sep 08, 2018 - 00:42 UTC
Update
The team has identified the cause of the issue and is still working to resolve this. We will continue to provide a status update as it changes. Thank you for your patience.
Posted 15 days ago. Sep 08, 2018 - 00:36 UTC
Identified
Issue has been identified and we are working to resolve this. Will provide and update in the next ten minutes.
Posted 15 days ago. Sep 08, 2018 - 00:20 UTC
Investigating
Alert triggered for the site and investigating the cause. More updates soon.
Posted 15 days ago. Sep 08, 2018 - 00:07 UTC
This incident affected: Atlas and Terraform Runs.