Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
HCP Waypoint Polling Disabled
Incident Report for HashiCorp Services
Resolved
Our Engineering team has re-enabled polling features and resolved the underlying issues. Status report and datasource polling should now be operating normally. If you continue to experience any problems, please open a ticket with our support team.
Posted Apr 19, 2023 - 00:21 UTC
Identified
Polling features in HCP waypoint are currently disabled in HCP Waypoint as the engineering team investigates and remediates performance issues related to the feature.


Features impacted:
- Projects with direct datasource polling enabled, via `waypoint project apply -poll` (https://developer.hashicorp.com/waypoint/commands/project-apply#poll), will not automatically queue jobs for runners to trigger automatic deployments based on git changes.
- Projects with status report polling enabled, via `waypoint project apply -app-status-poll (https://developer.hashicorp.com/waypoint/commands/project-apply#app-status-poll) will not automatically queue poll jobs for runners to check the status of deployed instances. Status reports can still be triggered manually with `waypoint status -refresh` (https://developer.hashicorp.com/waypoint/commands/status#refresh).


We apologize for the inconvenience and will update when polling features are re-enabled.
Posted Apr 13, 2023 - 16:59 UTC
This incident affected: HCP Waypoint.