Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
Short period of application errors
Incident Report for HashiCorp Services
Resolved
Due to underlying AWS failure, we had a Vault leader transition resulting in 15 seconds of errors in encrypting and decrypting variables. These errors were returned from 2017-04-17 18:27:45 - 2017-04-17 18:28:00 UTC. We are following up with tasks to add retry behavior to downstream clients so we can sustain Vault leader transitions and recover without returning errors to users.
Posted Apr 17, 2017 - 18:53 UTC
Investigating
We're investigating a spat of application-level errors stemming from an internal Vault service interruption affecting variable decrypt/encrypt operations. The batch of errors appears to be limited to a short timespan, but we will follow up as we learn more.
Posted Apr 17, 2017 - 18:38 UTC