Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
Increased error rate affecting linux package downloads
Incident Report for HashiCorp Services
Resolved
This incident has been resolved as the APT and RPM repositories/packages are operating normally.
Posted Dec 09, 2022 - 18:01 UTC
Monitoring
We are happy to report that RHEL packages are operational. We are continuing to monitor this. Thank you everyone for your continued support and patience. At this point, APT and RPM packages are fully restored.

As part of the incident, the repo configuration for RPM based linux repositories might be caching an incorrect file. If you are running into issues syncing the repo, please re-add the repo config from https://rpm.releases.hashicorp.com/{fedora,RHEL,AmazonLinux}/hashicorp.repo. To do this using wget, run: `wget -O- https://rpm.releases.hashicorp.com/RHEL/hashicorp.repo | sudo tee /etc/yum.repos.d/hashicorp.repo`. If you are building docker images, the incorrect version may be cached in a layer and requires a `docker build --nocache` to pull the correct version.
Posted Dec 09, 2022 - 15:21 UTC
Update
We are happy to report complete restored availability for the AmazonLinux and Fedora packages. A subset of RHEL packages are still degraded, and we are actively working on a fix. We will provide another update when RHEL package availability is fully restored. Thank you for your patience.
Posted Dec 09, 2022 - 07:52 UTC
Update
We are currently restoring RPM packages, but anticipate that this will take some time to get things operating normally again.
Posted Dec 09, 2022 - 02:21 UTC
Update
We have completed our APT package sync and folks should be able successfully to pull apt packages now. RPMs packages are still affected. We will update the the statuspage once they are working again.
Posted Dec 08, 2022 - 23:57 UTC
Investigating
As of 22:45 UTC, we are seeing increased error rates from users downloading HashiCorp linux packages, which includes a subset of APT and RPM packages. The team is investigating and working on a resolution. We will post an update shortly.
Posted Dec 08, 2022 - 23:21 UTC
This incident affected: Releases (APT Repository, RPM Repository).