Waypoint URL Service latency and availability issues
Resolved·Partial outage

This incident has been resolved. The Waypoint URL service should be functioning without issue.

Fri, Oct 16, 2020, 10:26 PM
(4 years ago)
·
Affected components
Waypoint URL Service
Updates

Resolved

This incident has been resolved. The Waypoint URL service should be functioning without issue.

Fri, Oct 16, 2020, 10:26 PM

Monitoring

We've rolled out some changes to the URL service that we expect to stabilize it, but it is running in a partially degraded state so there may still be latency or other minor delays.

Fri, Oct 16, 2020, 06:14 PM(4 hours earlier)

Identified

Following user reports on GitHub, we've identified an issue with the Waypoint URL service that occasionally results in high latency for connections to waypoint.run hosts, as well as scenarios where a new deployment will return the "Couldn't find a Waypoint deployment with this URL" error page. We've root caused the issue as various performance related problems caused by increased load following the launch of the service.

Fri, Oct 16, 2020, 06:06 PM

Identified

Investigating user reports of issues with waypoint.run hosts.

Fri, Oct 16, 2020, 06:06 PM