Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
Auth0 outage impacting HCP Portal
Incident Report for HashiCorp Services
Resolved
HashiCorp Cloud Platform users are continuing to successfully signup, login, and authenticate with service principals (Terraform Providers for talking to the HCP platform). This incident is resolved.
Posted Apr 21, 2021 - 10:04 UTC
Update
HashiCorp Cloud Platform users are continuing to successfully signup, login, and authenticate with service principals (Terraform Providers for talking to the HCP platform). Auth0 has cleared the outage on their end and we will continue to monitor for any further fallout.
Posted Apr 20, 2021 - 21:53 UTC
Update
We are seeing HashiCorp Cloud Platform users are once again able to signup, login, and authenticate with service principals (Terraform Providers for talking to the HCP platform). We believe there's still a chance to receive stale data from Auth0 and we will continue to monitor the situation to ensure any data staleness issues are resolved.
Posted Apr 20, 2021 - 21:12 UTC
Update
We are starting to see some recovery of authentication to the HCP Portal. HashiCorp Cloud Platform signups, logins, and service principals (Terraform Providers for talking to the HCP platform) may be recovering, though we are continuing to monitor the situation to confirm. Existing HCP Consul, HCP Vault, and HCS dataplanes are not affected at this time.
Posted Apr 20, 2021 - 20:18 UTC
Update
We are continuing to monitor the situation with Auth0 authentication. HashiCorp Cloud Platform signups, logins, and service principals (Terraform Providers for talking to the HCP platform) are currently not working. Existing HCP Consul, HCP Vault, and HCS dataplanes are not affected at this time.
Posted Apr 20, 2021 - 19:26 UTC
Update
We are continuing to monitor the situation with Auth0 authentication. HashiCorp Cloud Platform signups, logins, and service principals (Terraform Providers for talking to the HCP platform) are currently not working. Existing HCP Consul, HCP Vault, and HCS dataplanes are not affected at this time.
Posted Apr 20, 2021 - 18:16 UTC
Update
We are continuing to monitor the situation with Auth0 authentication on the platform. HashiCorp Cloud Platform signups, logins, and service principals (Terraform Providers for talking to the HCP platform) are currently not working. Existing HCP Consul, HCP Vault, and HCS dataplanes are not affected at this time.
Posted Apr 20, 2021 - 17:43 UTC
Update
HashiCorp Cloud Platform signups, logins, and service principals (Terraform Providers for talking to the HCP platform) are currently not working. We continue to monitor the situation with Auth0 and will update as we have more information.
Posted Apr 20, 2021 - 16:43 UTC
Monitoring
We believe that HashiCorp Cloud Platform signups and logins are currently not working. We are monitoring the situation with Auth0 and will update as we have more information.
Posted Apr 20, 2021 - 16:37 UTC
Investigating
We're aware of an incident affecting Auth0 authentication and sessions, which in turn affects authentication and authorization of the HCP portal. We'll post another update as we learn more.
Posted Apr 20, 2021 - 16:23 UTC
This incident affected: HCP Portal.