Email verification not working
Resolved·Degraded performance

We've confirmed emails are successfully being sent, and still-valid verifications have been resent. If you tried to verify your account more than 10 minutes ago, please use our "Resend email verification" banner button to try again.

Mon, May 24, 2021, 02:01 PM
(4 years ago)
·
Affected components
HCP Portal
Updates

Resolved

We've confirmed emails are successfully being sent, and still-valid verifications have been resent. If you tried to verify your account more than 10 minutes ago, please use our "Resend email verification" banner button to try again.

Mon, May 24, 2021, 02:01 PM

Monitoring

We believe we have implemented a fix for this issue, and will continue to monitor that emails are successfully being sent. If you haven't received a verification email that you expected, please use our "Resend email verification" banner.

Mon, May 24, 2021, 01:15 PM(45 minutes earlier)

Identified

We're aware of an issue with email verifications for new signups. We're working with our internal teams to identify a fix. Existing, verified accounts are not affected at this time.

Mon, May 24, 2021, 12:54 PM(21 minutes earlier)