Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
HCP audit log streaming beta users may see delays
Incident Report for HashiCorp Services
Resolved
This issue has been fully resolved as of 1800 UTC. We are seeing full recovery of HCP audit log streaming to all destinations. If you have further questions about this incident or need additional assistance, please contact your support team. Thank you.
Posted Nov 15, 2024 - 18:01 UTC
Update
We're more than halfway through delivery of the the backed up audit log streaming messages. We'll continue to monitor and post a final update once HCP audit log streaming destinations are all completely caught up.
Posted Nov 15, 2024 - 17:10 UTC
Monitoring
We believe in the next 30 minutes that that all streaming messages will be caught up and all audit log streaming will be fully restored. The majority have already fully caught up and we have a fix in place to prevent further delays.
Posted Nov 15, 2024 - 16:29 UTC
Identified
We've identified what has caused processing delays in HCP audit log streaming, and some messages should now be coming through to streaming destinations. We are working on a permanent fix and we'll post another update as we begin to catch up on messages significantly.
Posted Nov 15, 2024 - 16:02 UTC
Investigating
We have encountered a problem in processing and externally streaming new HCP audit logs since 8:49am UTC. These logs have not been dropped, and we are investigating why logs aren't being delivered at this time.

HCP Boundary, HCP Vault Secrets, and HCP Audit Log Streaming beta users will not be able to create, update, or delete new streaming destinations. Existing destinations are still in place and will continue to be used for streaming once we resolve this issue.
Posted Nov 15, 2024 - 15:41 UTC
This incident affected: HCP API.