Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
Investigating an issue with new project creation
Incident Report for HashiCorp Services
Resolved
We believe this issue has been resolved, and we'll be discontinuing updates at this time. If you need further help or information, please contact your HashiCorp Support team.
Posted Jul 31, 2024 - 14:35 UTC
Monitoring
We are continuing to monitor recovery, but we believe the impact to HashiCorp customers from this incident has concluded. We have deployed a workaround and will restore fully service once our cloud provider has recovered as well.

We are aware of a small number of projects (

We will post another update in approximately 12 hours, to wrap up our communications on this issue.
Posted Jul 31, 2024 - 03:29 UTC
Update
We have deployed some workarounds and re-enabled new project creation. Some existing projects that were created during this incident may be affected, but we will be working to remediate those in the next day.

We are also continuing to monitor underlying cloud provider recovery and will restore workarounds to normal state once that occurs.
Posted Jul 31, 2024 - 03:17 UTC
Update
We're continuing to work on mitigation for this incident so that we may restore project creation and other HCP capabilities, as we also monitor the underlying cloud provider recovery as well.
Posted Jul 31, 2024 - 03:04 UTC
Update
While we continue to monitor the underlying cloud provider incident, we're also deploying some workarounds so that we can re-enable functionality like new project creation. We hope to report that we have workarounds in place and can consider the impact mitigated soon.
Posted Jul 31, 2024 - 02:38 UTC
Update
We are continuing to monitor the situation, as well as investigate workarounds to unpause project creation. We will post additional updates every 30 minutes or if the situation changes.
Posted Jul 31, 2024 - 02:17 UTC
Identified
We have confirmed that our project creation issues are related to an underlying cloud provider issue. At this time, we're keeping project creation disabled.

We also identified less than 20 projects affected during the course of this incident, up to our disabling of new project creation.

We will be investigating additional mitigation options and monitoring the situation, and you can expect additional regular updates or as needed updates if there's a status change.
Posted Jul 31, 2024 - 01:43 UTC
Update
We have disabled new project creation while we continue to investigate why some project operations are failing.
Posted Jul 31, 2024 - 00:44 UTC
Investigating
Our engineering team is investigating an issue with creating new HashiCorp Cloud Platform projects. New projects created during this time may also have issues and errors and fail to show information like billing details. We will share another update as soon as we have more information.
Posted Jul 31, 2024 - 00:21 UTC
This incident affected: HCP Portal.