Sporadic Delays Impacting Terraform Runs Triggered from Large Source Repositories
Incident Report for HashiCorp Services
Resolved
We have taken actions to isolate the source of delay and mitigate the issue alongside evacuating the location exacerbating the delays. Run performance and completion has stabilized within normal ranges.
Posted 14 days ago. Mar 06, 2019 - 17:19 UTC
Monitoring
We have isolated the source of the delays as sporadic slow upload behavior for Terraform plans triggered from large source repositories. A library that our codebase is dependent upon contains logic that exhibited latency in reproductions, and we are continuing to address it. Additionally, We have evacuated the location experiencing much slower upload times. We have high confidence that this will address the delays. We will continue to monitor to verify and provide updates as they become available.
Posted 26 days ago. Feb 22, 2019 - 21:28 UTC
Identified
We have identified the source of an issue impacting Terraform plans triggered from large source repositories. Some plans may experience sporadic delays between completion and ability to apply. We are working to implement a resolution and will provide updates as they become available.
Posted 27 days ago. Feb 21, 2019 - 21:03 UTC
This incident affected: Terraform Runs.