Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
HCP Terraform Dynamic Credentials failure to assume role based on run phase
Incident Report for HashiCorp Services
Resolved
Our Engineering team has resolved an issue assuming roles with Dynamic Provider Credentials based on plan vs apply run phases
If you continue to experience any problems, please open a ticket with our support team.
Posted Sep 10, 2024 - 22:03 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue assuming roles with Dynamic Provider Credentials based on plan vs apply run phases.

We are monitoring to ensure that this issue is resolved
Posted Sep 10, 2024 - 19:48 UTC
Investigating
Our engineering team is investigating an issue with HCP Terraform Dynamic Provider Credentials containing the incorrect run phase in the subject claim.
Dynamic Provider Credentials users who rely on run-phase based matching to assume roles in their cloud providers may see authentication errors in their HCP Terraform runs
Posted Sep 10, 2024 - 19:14 UTC