Subscribe to HashiCorp Status updates via Atom or RSS Feed or contact Support.
HCP Consul Creation and Updates Failures
Incident Report for HashiCorp Services
Resolved
We have now pushed changes to production and are no longer seeing any clusters in unhealthy states.
Incident resolved
Posted Oct 27, 2022 - 01:22 UTC
Update
Promotion to production environment is currently occurring and will update when complete
Posted Oct 27, 2022 - 00:46 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 27, 2022 - 00:45 UTC
Update
Changes have been pushed to our remote development environments and we are working to validate changes before promoting to production.
Posted Oct 26, 2022 - 23:38 UTC
Monitoring
Currently our engineers are working to make corrections to resolve the issue. Updates will be issued when the changes have been rolled out to the production environment.
Posted Oct 26, 2022 - 22:18 UTC
Identified
The Consul engineering team has located the cause of the issue and began to roll out the fix.
We will continue to provide updates as the changes are made to verify the recovery of the Consul cluster and node create/update actions.
Posted Oct 26, 2022 - 22:02 UTC
Investigating
HCP Consul is current experiencing issues on new cluster creation and updates leaving the clusters or nodes stuck in the updating/creating state.
We are currently investigating this and will provide updates.
Posted Oct 26, 2022 - 21:50 UTC
This incident affected: HCP Consul Dedicated (AWS-ap-southeast-1, AWS-ap-southeast-2, AWS-eu-central-1, AWS-eu-west-1, AWS-eu-west-2, AWS-us-east-1, AWS-us-west-2).